1) How to start TSM B/A Client schedule services in AIX in background?
2) How to start TSM web client services in AIX ?
3) How to start B/A client in web-browser ?
4) How to start the TSM LANFree storage agent services in AIX ?
5) How to check the TSM services are running in AIX ?
6) How to start the TSM services in AIX ?
and then run below command to start in background
7) How to kill the TSM services in AIX ?
First check the services by using ---- > # ps -ef | grep -i dsmserv
It will list out the process id's, then cancel the process id by using below command
8) How to check the tape devices list in AIX ?
9) How to check the adapters in AIX ?
10) How to check the errors in OS level in AIX ?
12) How to create the new file in AIX ?
13) How to read last 200 lines in any file ?
14) How to check the file size in AIX ?
15) How to verify the list of files in a directory ?
16) How to change the ownership of the file ?
17) How to copy the file from one dir to another dir ?
18) How to check the IP address in AIX ?
19) How to check the hostname of the server ?
20) How to check the communication b/w from one server to another server in AIX ?
21) How to check if the port number is working or not in AIX ?
22) How to create a new directory in AIX ?
23) how to move (cut/paste) the files form one directory to another directory in AIX?
24) To remove/delete the directory and files in AIX ?
25) To check which software applications are installed in AIX ?
26) How to edit any file, for example dsm.sys file ?
use i to go to insert mode, a to append mode , x to delete letters
27) How to change permissions of a file/directory ?
28) How to configure tape devices in AIX ?
Running cfgmgr command will scan all the devices attached to the AIX machine
29) How to install any software packages in AIX ?
30) How to uninstall software packages for example all the tsm client softwares ?
Go to /opt/tivoli/tsm/_uninst and run ./Uninstall_Tivoli_Storage_Manager -i console command
# cd /usr/tivoli/tsm/client/ba/bin
# nohup dsmc sched &
2) How to start TSM web client services in AIX ?
# nohup dsmcad &
3) How to start B/A client in web-browser ?
http://ip.address.of.server>:1581
4) How to start the TSM LANFree storage agent services in AIX ?
# cd /usr/tivoli/tsm/StorageAgent/bin
# nohup ./dsmsta &
5) How to check the TSM services are running in AIX ?
# ps -ef | grep -i dsmserv
6) How to start the TSM services in AIX ?
For TSM 5.5 --> # cd /usr/tivoli/tsm/server/bin
For TSM 6.X --> # cd /opt/tivoli/tsm/server/bin
and then run below command to start in background
# ./dsmserv &
7) How to kill the TSM services in AIX ?
First check the services by using ---- > # ps -ef | grep -i dsmserv
It will list out the process id's, then cancel the process id by using below command
# kill -9 <PID no>
8) How to check the tape devices list in AIX ?
# lsdev -Cc tape
9) How to check the adapters in AIX ?
# lsdev -Cc adapter
10) How to check the errors in OS level in AIX ?
# errpt -a
11) How to check the tape serial number in AIX ?
# lscfg -vpl <devicename> (Ex- rmt1)
12) How to create the new file in AIX ?
# cat>file name OR
# touch <filename> OR
# vi <filename>
13) How to read last 200 lines in any file ?
# tail -200 <filename>
14) How to check the file size in AIX ?
# df -k <filesystemname> (To check in kbs)
# df -m <filesystemname>(To check in mbs)
# df -g <filesystemname> (To check in gbs)
15) How to verify the list of files in a directory ?
# ls -ltr
16) How to change the ownership of the file ?
# chown username:groupname <filename>
17) How to copy the file from one dir to another dir ?
# cp <filename> /dir/dir/<filename>
18) How to check the IP address in AIX ?
# ifconfig -a
19) How to check the hostname of the server ?
# hostname
20) How to check the communication b/w from one server to another server in AIX ?
# ping ipaddress
21) How to check if the port number is working or not in AIX ?
# netstat -an <portnumber>
ex: # netstat -an 1500
22) How to create a new directory in AIX ?
# mkdir <directoryname>
23) how to move (cut/paste) the files form one directory to another directory in AIX?
# mv /dir1/dir2<filename> /dir4/dir5/dir6/<filename>
24) To remove/delete the directory and files in AIX ?
# rmdir -r <dirname> -r --> deletes subdirectories also
25) To check which software applications are installed in AIX ?
To check TSM, run ------- > # lslpp - l tivoli.tsm*
26) How to edit any file, for example dsm.sys file ?
# vi dsm.sys
use i to go to insert mode, a to append mode , x to delete letters
27) How to change permissions of a file/directory ?
# chmod 777 <file/dirname>
Running cfgmgr command will scan all the devices attached to the AIX machine
# cfgmgr
29) How to install any software packages in AIX ?
using # smitty installp OR
# installp -agXd /softwares/install.bin
Ex: # installp -agXd .tsmsoft/install.bin
# smitty remove tivoli.tsm.*
# installp -ug tivoli.tsm.*
Go to /opt/tivoli/tsm/_uninst and run ./Uninstall_Tivoli_Storage_Manager -i console command
I have a different scenario expecting a bit help here...
ReplyDeletei have 8 LPARS have one
IBM TS3200 tape library.
When i fire the command on lpars the following output generates
lsdev -Cc tape the output is
rmt0 Available 16-T1-01 IBM 3580 Ultrium Tape Drive (FCP)
rmt1 Available 16-T1-01 IBM 3580 Ultrium Tape Drive (FCP)
smc0 Available 16-T1-01 IBM 3573 Tape Medium Changer (FCP)
but one of my lpars gives the following output
rmt0 Available 00-00-00 SAS 4mm Tape Drive
how to add ultrium tape drive to my that particular lpar
if you can show me or help either way or refer to any post where i can do it myself will be great
This comment has been removed by the author.
ReplyDeleteI presume the tape library consists all ULTRIUM tape drives, then how come the lpar is showing different tape device in some Lpar. IF your Lpar is showing wrong information about the tape device then you need to modify it.
ReplyDeleteIf there is a second library with SAS 4mm tape then you need to configure that library seperately
okay.. we have one media enclosure that is assign to lpar..hence it is showing differently from others
ReplyDeletei can assign or move media(SAS4mm)to other lpar using HMC
but how can i assign tapes to that particular lpar