What version, release, and maintenance level of AIX is running on my system?
Type one of the following:
oslevel -r
|
lslpp -h bos.rte
|
How can I determine which fileset updates are missing from a particular AIX level?
oslevel -rl 5300-04
|
What SP (Service Pack) is installed on my system?
To see which SP is currently installed on the system, run the
oslevel -s
command. Sample output for an AIX 5L Version 5.3 system,
with TL4, and SP2 installed, would be:oslevel –s
5300-04-02
|
Is a CSP (Concluding Service Pack) installed on my system?
oslevel -s
command. Sample output for an AIX 5L Version 5.3 system, with TL3, and CSP installed, would be:oslevel –s
5300-03-CSP
|
How do I create a file system?
The following command will create, within volume group testvg, a jfs file system of 10MB with mounting point /fs1:
crfs -v jfs -g testvg -a size=10M -m /fs1
|
The following command will create, within volume group testvg, a jfs2 file system of
10MB with mounting point /fs2 and having read-only permissions:
crfs -v jfs2 -g testvg -a size=10M -p ro -m /fs2
|
How do I change the size of a file system?
To increase the
/usr
file system size by 1000000 512-byte blocks, type:chfs -a size=+1000000 /usr
|
Note: In AIX V5.3, the size of a JFS2 file system can be shrunk, as well.
Type the following:
mount -V cdrfs -o ro /dev/cd0 /cdrom
|
How do I mount a file system?
The following command will mount file system /dev/fslv02 on the /test directory:
mount /dev/fslv02 /test
|
The following command will mount all such file systems:
mount {-a|all}
|
How do I unmount a file system?
Type the following command to unmount /test file system:
umount /test
|
How do I display mounted file systems?
Type the following command to display information about all currently mounted file systems:
mount
|
How do I remove a file system?
Type the following command to remove the /test file system:
rmfs /test
|
How can I defragment a file system?
The
defragfs
command can be used to improve or report the status of contiguous space
within a file system. For example, to defragment the file system /home,
use the following command:defragfs /home
|
Which fileset contains a particular binary?
To show
bos.acct
contains /usr/bin/vmstat
, type:lslpp -w /usr/bin/vmstat
|
Or to show
bos.perf.tools
contains /usr/bin/svmon
, type:which_fileset svmon
|
How do I display information about installed filesets on my system?
Type the following:
lslpp -l
|
How do I determine if all filesets of maintenance levels are installed on my system?
Type the following:
instfix -i | grep ML
|
How do I determine if a fix is installed on my system?
To determine if IY24043 is installed, type:
instfix -ik IY24043
|
How do I install an individual fix by APAR?
To install APAR IY73748 from
/dev/cd0
, for example, enter the command:instfix -k IY73748 -d /dev/cd0
|
How do I verify if filesets have required prerequisites and are completely installed?
To show which filesets need to be installed or corrected, type:
lppchk -v
|
How do I get a dump of the header of the loader section and the symbol entries in symbolic representation?
Type the following:
dump -Htv
|
How do I determine the amount of paging space allocated and in use?
Type the following:
lsps -a
|
How do I increase a paging space?
You can use the
chps -s
command to dynamically increase the size of a paging space. For
example, if you want to increase the size of hd6 with 3 logical
partitions, you issue the following command:chps -s 3 hd6
|
How do I reduce a paging space?
You can use the chps
-d
command to dynamically reduce the size of a paging space. For example,
if you want to decrease the size of hd6 with four logical partitions,
you issue the following command:chps -d 4 hd6
|
How would I know if my system is capable of using Simultaneous Multi-threading (SMT)?
Your system is capable of SMT if it's a POWER5®-based system running AIX 5L Version 5.3.
How would I know if SMT is enabled for my system?
If you run the
smtctl
command without any options, it tells you if it's enabled or not.
Is SMT supported for the 32-bit kernel?
Yes, SMT is supported for both 32-bit and 64-bit kernel.
How do I enable or disable SMT?
You can enable or disable SMT by running the
smtctl
command. The following is the syntax:
smtctl [ -m off | on [ -w boot | now]]
|
The following options are available:
-m off | Sets SMT mode to disabled. |
-m on | Sets SMT mode to enabled. |
-w boot | Makes the SMT mode change effective on
next and subsequent reboots if you run the bosboot command before the next system reboot. |
-w now | Makes the SMT mode change immediately but will not persist across reboot. |
If neither the
-w
boot or the -w
now options are specified, then the mode change is made immediately. It persists across subsequent reboots if you run the bosboot
command before the next system reboot.
How do I get partition-specific information and statistics?
The
lparstat
command provides a report of partition information and utilization
statistics. This command also provides a display of Hypervisor
information.
How do I know if my volume group is normal, big, or scalable?
Run the
lsvg
command on the volume group and look at the value for MAX PVs. The
value is 32 for normal, 128 for big, and 1024 for scalable volume group.
How can I create a volume group?
Use the following command, where
s
partition_size
sets the number of megabytes (MB) in each physical partition where
the partition_size is expressed in units of MB from 1 through 1024.
(It's 1 through 131072 for AIX V5.3.) The partition_size variable must
be equal to a power of 2 (for example: 1, 2, 4, 8). The default value
for standard and big volume groups is the lowest value to remain within
the limitation of 1016 physical partitions per physical volume. The
default value for scalable volume groups is the lowest value to
accommodate 2040 physical partitions per physical volume.mkvg -y name_of_volume_group -s partition_size list_of_hard_disks
|
How can I change the characteristics of a volume group?
You use the following command to change the characteristics of a volume group:
chvg
|
How do I create a logical volume?
Type the following:
mklv -y name_of_logical_volume name_of_volume_group number_of_partition
|
How do I increase the size of a logical volume?
To increase the size of the logical volume represented by the lv05 directory by three logical partitions, for example, type:
extendlv lv05 3
|
How do I display all logical volumes that are part of a volume group (for example, rootvg)?
You can display all logical volumes that are part of rootvg by typing the following command:
lsvg -l rootvg
|
How do I list information about logical volumes?
Run the following command to display information about the logical volume lv1:
lslv lv1
|
How do I remove a logical volume?
You can remove the logical volume lv7 by running the following command:
rmlv lv7
|
The
rmlv
command
removes only the logical volume, but does not remove other entities,
such as file systems or paging spaces that were using the logical
volume.
How do I mirror a logical volume?
- mklvcopy LogicalVolumeName Numberofcopies
- syncvg VolumeGroupName
How do I remove a copy of a logical volume?
You can use the
rmlvcopy
command to remove copies of logical partitions of a logical volume. To
reduce the number of copies of each logical partition belonging to
logical volume testlv, enter:rmlvcopy testlv 2
|
Each logical partition in the logical volume now has at most two physical partitions.
Queries about volume groups
To show volume groups in the system, type:
lsvg
|
To show all the characteristics of
rootvg
, type:
lsvg rootvg
|
To show disks used by
rootvg
, type:
lsvg -p rootvg
|
How to add a disk to a volume group?
Type the following:
extendvg VolumeGroupName hdisk0 hdisk1 ... hdiskn
|
How do I find out what the maximum supported logical track group (LTG) size of my hard disk?
You can use the
lquerypv
command with the -M
flag. The output gives the LTG size in KB. For instance, the LTG size for hdisk0 in the following example is 256KB./usr/sbin/lquerypv -M hdisk0
256
|
You can also run the
lspv
command on the hard disk and look at the value for MAX REQUEST.
What does the
syncvg
command do?
The
syncvg
command
is used to synchronize stale physical partitions. It accepts names of
logical volumes, physical volumes, or volume groups as parameters.
For example, to synchronize the physical partitions located on physical volumes hdisk6 and hdisk7, use:
syncvg -p hdisk4 hdisk5
|
To synchronize all physical partitions from volume group testvg, use:
syncvg -v testvg
|
How do I replace a disk?
extendvg
VolumeGroupName hdisk_newmigratepv
hdisk_bad hdisk_newreducevg -d
VolumeGroupName hdisk_bad
How can I clone (make a copy of) the rootvg?
You can run the
alt_disk_copy
command to copy the current rootvg to an alternate disk. The following example shows how to clone the rootvg to hdisk1.alt_disk_copy -d hdisk1
|
0 Comment to "Basic Commands used in Logical Volume Manager (PV,VG,LV,LP,PP,FS)"
Post a Comment